当前位置:首页 > 原创教程 > RouterOS对DHCP对绑定的静态IP进行网关和DNS自定义

RouterOS对DHCP对绑定的静态IP进行网关和DNS自定义

原创教程 / 星之宇 / 2024-3-30 11:55 / 浏览:380 / 评论:0

RouterOS默认的DHCP服务器已经设置了网关和DNS, 但是有时候需要给部分终端指定不同的网关和DNS。一般可用于部分终端走OpenWrt旁路由, 其他终端直接走RouterOS直接出去。


操作方法

1、使用Winbox进行DHCP Option设置,IP --> DHCP Server --> Options --> +,添加以下记录

自定义网关:Name: 77bx-gateway,Code: 3,Value: '10.0.0.1' (不要忘记value值是有单引号的)

自定义DNS:Name: 77bx-gateway,Code: 6,Value: '8.8.8.8'(不要忘记value值是有单引号的)

445-2.png


2、对终端IP进行静态绑定,IP --> DHCP Server --> Leases,选中要指定的终端,点击Make Static

445-1.png


3、再点开这个终端,DHCP Options选择77bx-gateway和77bx-dns这2个自定义的,点击OK

445-3.png


4、终端重新获取DHCP,发现已经按照刚才的配置生效了。

445-4.png


5、RouterOS命令

/ip dhcp-server option add code=3 name=77bx-gateway value="'10.0.0.1'"
/ip dhcp-server option add code=6 name=77bx-dns value="'8.8.8.8'"
/ip dhcp-server lease add address=10.1.0.59 dhcp-option=77bx-gateway,77bx-dns mac-address=08:00:27:63:EB:8F server=DHCP-WJ

目前有 0 条评论

    • 昵称
    • 邮箱
    • 网址