当前位置:首页 > 原创教程 > VMware ESXi安装VyOS并配置DHCP上网

VMware ESXi安装VyOS并配置DHCP上网

原创教程 / 星之宇 / 2023-4-5 20:51 / 浏览:6807 / 评论:0

开源路由操作系统VyOS是基于 Debian GNU/Linux 的网络操作系统,提供了和其他诸如Cisco的IOS、Juniper的JUNOS类似的操作方式,可提供基于软件的网络路由,防火墙和VPN功能。


一、环境介绍

1、VMware ESXi 6.7U3  (Build15160138)

2、VyOS镜像 vyos-1.4-rolling-202304050317-amd64,官网:https://vyos.io/


二、环境创建

1、点击 创建/注册虚拟机 ,选择 创建新虚拟机 ,点击 下一页

251-1.png


2、名称随便输入如VyOS,兼容性选择 ESXi 6.7 虚拟机 ,客户机操作系统系列选择 Linux ,客户机操作系统版本选择 Debian GNU/Linux 10(64位),点击 下一页

251-2.png


3、选择存储,一般默认即可,点击 下一页

251-3.png


4、CPU内存按实际情况设置即可,并增加一个网卡,CD/DVD驱动器1选择 数据存储ISO文件 ,选择vyos-1.4-rolling-202304050317-amd64.iso镜像,点击 下一页

251-4.png


5、配置列表,点击 完成 即可

251-5.png


三、VyOS安装

1、开启VyOS虚拟机,看到启动界面,选择 Live System(amd64-vyos) 回车

251-6.png


2、等待一分钟左右,会进入系统。并使用账号vyos密码vyos登陆

251-7.png


3、输入命令 install image 安装系统


4、是否继续,提示后直接回车或输入 yes 回车


5、格式化,提示后直接回车或输入 auto 回车,之后会显示当前的硬盘


6、选择安装硬盘,提示后直接回车或输入 sda 回车


7、是否继续,提示后输入 yes 回车


8、空间大小设置,提示后直接回车


9、选择安装镜像,提示后直接回车


10、配置文件,提示后直接回车


11、设置密码,提示后输入新密码回车,然后提示后再次重复输入密码回车


12、安装引导文件,提示后直接回车或输入 sda 回车


13、看到安装完,需要重启的提示,输入 reboot 命令重启

251-9.png


四、VyOS配置

1、重启重录后,按照以下基本配置,配置上网

#进入编辑模式
vyos@vyos# configure

#设置主机名
vyos@vyos# set system host-name 77bx-vyos

#设备时区
vyos@77bx-vyos# set system time-zone Asia/Shanghai

#配置外网接口 
vyos@77bx-vyos# set interfaces ethernet eth0 address 10.1.0.188/24
vyos@77bx-vyos# set interfaces ethernet eth0 description 'WAN'

#配置内网接口
vyos@77bx-vyos# set interfaces ethernet eth1 address 192.168.99.1/24
vyos@77bx-vyos# set interfaces ethernet eth1 description 'Lan'

#配置静态路由
vyos@77bx-vyos# set protocols static route 0.0.0.0/0 next-hop 10.1.0.1 distance 60

#配置NAT转换
vyos@77bx-vyos# set nat source rule 100 outbound-interface eth0
vyos@77bx-vyos# set nat source rule 100 source address 192.168.99.0/24
vyos@77bx-vyos# set nat source rule 100 translation address masquerade

#配置dns服务
vyos@77bx-vyos# set system name-server 10.1.0.1
vyos@77bx-vyos# set service dns forwarding allow-from 192.168.99.0/24
vyos@77bx-vyos# set service dns forwarding listen-address 192.168.99.1

#配置DHCP服务
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp authoritative
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp subnet 192.168.99.0/24 default-router 192.168.99.1
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp subnet 192.168.99.0/24 name-server 192.168.99.1
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp subnet 192.168.99.0/24 lease 86400
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp subnet 192.168.99.0/24 range exclude start 192.168.99.100
vyos@77bx-vyos# set service dhcp-server shared-network-name 77bx-dhcp subnet 192.168.99.0/24 range exclude stop 192.168.99.200

#保存提交
vyos@77bx-vyos# save
vyos@77bx-vyos# commit


2、客户端测试

251-10.png


3、其他可能用到命令

#回退
rollback
#删除配置(就是在命令行前加delete)
delete set system name-server 10.1.0.1

目前有 0 条评论

    • 昵称
    • 邮箱
    • 网址