当前位置:首页 > 程序开发

之前有项目使用支付宝PHP SDK v2版本不知道出现什么问题,老是出现各种各样的报错,由于用到支付宝的API功能不是很多使用SDK有点浪费,所以准备手动写个身份认证的类。


一、授权申请

1、支付宝身份认证能力开通:https://open.alipay.com/api/detail?code=I1080300001000044085(需要企业认证才可以开通,个人认证无法开通)

2、申请一个应用和密钥,绑定支付宝身份认证能力(教程请去支付宝支持帮助)

本文主要讲解如何借助DNSPOD的新版API接口来实现RouterOS的DDNS动态解析。

看到DNSPOD官网有即将下架老版本API的提示,所以使用新版本的API来写了一个更新接口。


一、创建Token添加域名

首先域名要在DNSPOD解析,然后在腾讯云后台开启的API Token。

详细开通API Token教程:https://console.cloud.tencent.com/cam/capi


二、PHP制作DNSPOD API动态解析接口

以下是我制作好的php解析接口,支持SSL

解析接口

http://api.77bx.com/dnspod/dnspod.php https://api.77bx.com/dnspod/dnspod.php


HTTP请求方式

POST/GET


请求参数

参数名称 必选 类型 描述 id 是 String 腾讯云API密钥SecretId key 是 String 腾讯云API密钥SecretKey domain 是 String 域名。如77bx.com record 否 String 主机记录。如不传默认为@ type 否 String 记录类型。如不传默认为A记录 ip 否 String IP地址。如不传默认为来源IPv4地址


请求事例

curl -X POST http://api.77bx.com/dnspod/dnspod.php -d "id=SecretId&key=SecretKey&domain=77bx.com&record=op&ip=1.1.1.1&type=A"


请求输出

返回提示 描述 0 表示更新成功(当前IP地址和域名IP地址相同也返回0) 1 参数错误 2 域名或API密钥错误 3 更新或API密钥错误


安全说明

1、本接口未记录所有的解析token和解析记录,但是服务器的访问日志会有链接记录(按照政策要求需保存6个月的日志)。虽然有日志但是本接口不提供任何查询。

2、建议使用独立的DNSPOD账号来使用本接口,重要的域名请自建PHP服务器用来解析。由于使用本接口出现的任何安全问题,本人概不负责。这边只能保证本人不会去做任何后门行为。这边建议如果使用了本接口请勤换token(token可以管理账号下的所有域名)。


源代码

暂时不提供


RouterOS脚本

#PPPoE :local pppoe "pppoe-out1" #DNSPOD Token :local secretid "secretid" :local secretkey "secretkey" #DNSPOD域名 :local record "op1" :local domain "77bx.com" #以下非专业人士请勿修改 :global ipold :local ipnew [/ip address get [/ip address find interface=$pppoe] address] :set ipnew [:pick $ipnew 0 ([len $ipnew] -3)] :if ($ipnew != $ipold ) do={ :local postdata "id=$secretid&key=$secretkey&domain=$domain&record=$record&ip=$ipnew" :local response [/tool fetch http-method="post" url=http://api.77bx.com/dnspod/dnspod.php http-data=$postdata as-value output=user] :if ($response->"data" = "0") do={ :log info "DDNS: changed $ipold to $ipnew" :set ipold $ipnew } }

以上脚本需要修改pppoe(宽带拨号的名称),secretid,secretkey,record和domain

注意:ROS可以设置定时1分钟执行一次脚本,脚本中带有ip是否相同判断,相同就不执行;然后是我做的API接口后台中也有ip是否相同的判断,一般不会引起DNSPOD锁域名的情况。

因为有项目要用到支付宝当面付,所以就有了这次开发记录。

支付宝SDK:https://opendocs.alipay.com/open/54/103419

支付宝当面付官方文档:https://opendocs.alipay.com/open/f540afd8_alipay.trade.precreate?pathHash=d3c84596&ref=api&scene=19


一、授权申请

1、支付宝当面付能力开通,需要企业认证才可以开通,个人认证无法开通

[宝塔BT]Redis可视化管理工具-Redis管理器

插件介绍

Redis管理器,一款宝塔面板后台的Redis可视化管理工具。可以对本机或者远程Redis服务器进行查看、修改等操作,实现对Redis字符串String、哈希Hash、列表List、集合Set、有序集合Zset的修改保存操作,方便对Redis进行管理。


支持系统

1、Linux系统:Debian10到Debian11,CentOS8,其他的系统未测试(大概率支持)

2、Windows系统:Windows2019 64位

支付宝身份验证API开发记录

因为有项目要用到支付宝人脸认证,所以就有了这次开发记录。

支付宝SDK:https://opendocs.alipay.com/open/54/103419

支付宝身份认证官方文档:https://opendocs.alipay.com/open/20181012100420932508/api


一、授权申请

1、支付宝身份认证能力开通:https://app.alipay.com/abilityprod/detail?abilityCode=AM010501000000015744 (需要企业认证才可以开通,个人认证无法开通)

2、申请一个应用和密钥,绑定支付宝身份认证能力(教程请去支付宝支持帮助)

我前面有文章《RouterOS利用DNSPOD的API接口实现DDNS动态解析》写过通过PHP服务器更新DNSPOD解析的域名IP,但是更多的是带来安全问题,所有这次写了一个RouterOS(以下简称ROS)的原生脚本来实现域名的动态解析。


版本说明

1、最低版本支持RouterOS v6.43,低于这个版本的要么升级,要么还是使用第三方服务器来动态解析。

2、不存在的记录,不会自动添加,需要手动在DNSPOD添加记录,线路为默认,不支持单记录多线路解析。为什么不加自动了添加域名之类的,因为一次添加永久有效,所以脚本中不添加自动了。节省ROS性能(我懒)

3、只支持IPv4,不支持IPv6

推荐

本文主要讲解如何借助阿里云aliyun的云解析API接口来实现RouterOS(以下简称ROS)的DDNS动态解析。


一、创建访问控制RAM的AccessKey

我这边简单的讲讲如何申请开通:

1、阿里云网站 --> 产品 --> 安全 --> 应用身份服务,这个就是控制API ,用户管理,新建用户,填写用户名和勾上“为该用户自动生成AccessKey”,保存好这个accesskey。


2、策略管理 --> 自定义授权策略,新建授权策略,选择空白模版,授权策略名称随便填(如alidns),策略内容为下面的内容(修改下面内容中的域名为你自己要做DDNS的域名)

七牛镜像存储插件for zblog

七牛云存储支持绑定域名(需要备案域名),全网 CDN 加速(多数据中心+多加速节点,上传下载均加速)、持续在线,可以无限扩展、用户只需按需付费,无硬件投资,并且还有免费套餐的,每个月 10G 流量,总空间 10GB。

七牛的传统 CDN 的镜像存储,这个功能是七牛最强悍的地方,因为对于很多站点来说,有了这个功能,就无需将原来的图片上传到七牛的服务器上,只需在自己站点做些简单的修改,就可以使用七牛的 CDN 服务了,真正显示一键实现博客静态文件 CDN 加速。

七牛镜像存储 zblog php插件,这个插件是最近看了一下七牛和zblog后制作的,发现只有官方开发人员发布的那个集成到ueditor中去的七牛云存储插件,使用手动上传文件,通过服务器上传到七牛云储存。