当前位置:首页 > 原创教程 > 华三路由器基础配置

华三路由器基础配置

原创教程 / 星之宇 / 2021-9-11 14:37 / 浏览:2665 / 评论:0

本文主要是华三H3C路由器基础配置教程:配置DHCP和外网IP。


1、网络拓扑

使用华三的HCL测试路由器下内网电脑能访问外部网站。

127-1.png


2、路由器配置

2.1 重命名路由器名称

<h3c>system-view

[h3c]sysname R1


2.2 开启并配置dhcp服务

[R1]dhcp enable

[R1]dhcp server ip-pool vlan100  //创建dhcp地址池

[R1-dhcp-pool-vlan100]network 192.168.100.0 mask 255.255.255.0  //配置vlan100的网段和掩码

[R1-dhcp-pool-vlan100]gateway-list 192.168.100.1  //创建vlan100的网关

[R1-dhcp-pool-vlan100]dns-list 192.168.100.1  //dhcp分配的dns

[R1-dhcp-pool-vlan100]expired day 7  //有效期7天

[R1-dhcp-pool-vlan100]address range 192.168.100.100 192.168.100.200  //分配IP地址池

[R1-dhcp-pool-vlan100]quit

[R1]dns proxy enable  //开启dns代理功能

[R1]dhcp server forbidden-ip 192.168.100.100 192.168.100.110  //禁止分配的ip

127-2.png


2.3 配置VLAN

[R1]vlan 100

[R1-vlan100]quit

[R1]interface Vlan-interface 100

[R1-Vlan-interface100]ip address 192.168.100.1 255.255.255.0 //配置vlan100的网关和子网掩码,注意和2.2的dhcp保持一致

[R1-Vlan-interface100]quit

[R1]interface GigabitEthernet 0/1  //该接口接的是内网电脑

[R1-GigabitEthernet0/1]port link-mode bridge  //二层接口,模式应该是bridge

[R1-GigabitEthernet0/1]port link-type access  //接口改为briage模式下才可以配置为access模式

[R1-GigabitEthernet0/1]port access vlan 100


2.4 配置外网

[R1]interface GigabitEthernet 0/0  //外网接在这个端口上

[R1-GigabitEthernet0/0]ip address 10.0.0.188 255.255.255.0  //设置外网ip地址

[R1-GigabitEthernet0/0]quit

[R1]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1  //默认路由器配置

[R1]dns server 10.0.0.1  //dns配置,路由器要访问域名需要配置


2.5 NAT配置

内网用户通过路由器的nat地址池来访问Internet

[R1]nat address-group 1 name ChinaNET  //设置nat组

[R1-address-group-1-ChinaNET]address 10.0.0.188 10.0.0.188 //设置nat地址池

[R1-address-group-1-ChinaNET]quit

[R1]acl number 2000 name Internet

[R1-acl-ipv4-basic-2000]rule 0 permit source 192.168.100.0 0.0.0.255  //nat转换地址段

[R1-acl-ipv4-basic-2000]rule 1 deny

[R1-acl-ipv4-basic-2000]quit

[R1]interface GigabitEthernet 0/0

[R1-GigabitEthernet0/0]nat outbound 2000 address-group 1  //在外网接口加上nat转换


2.6 其他配置

比如管理账号配置等,这边不详细说明了。附上述配置的截图

127-3.png


3、环境测试

3.1 路由器默认是不开启路径回显的,所以要通过一下命令开启显示。不然Tracert都是***

[R1]ip ttl-expires enable

[R1]ip unreachables enable

[R1]save force  //保存配置,最后一定要做一下,不然下次启动之前的配置会丢失。


3.2 内网PC Ping和Tracert测试

由于模拟器的PC可以ping和Tracert只能使用ip地址,所以我通过Host主机再配置一个网卡,通过虚拟机下Win7做了测试。

127-4.png

目前有 0 条评论

    • QQ
    • 填好QQ,点击获取自动填写昵称和邮箱
    • 昵称
    • 邮箱
    • 网址