当前位置:首页 > 原创教程 > RouterOS配置邮箱并自动发送备份

RouterOS配置邮箱并自动发送备份

原创教程 / 星之宇 / 2022-11-20 19:39 / 浏览:63 / 评论:0

RouterOS(以下简称ROS)配置邮箱并发送备份到指定的邮箱地址。


一、RouterOS配置邮箱

1、Tools -> Email,打开Email Setting界面

Server:填入smtp地址(我这里用了阿里云企业邮箱,所以是smtp.qiye.aliyun.com)

Start TLS:选择yes或no(如果选择yes的时候,Port端口也会有所不同,yes一般是587,no一般是25)

Port:根据Start TLS以及邮箱官网的端口说明去配置(阿里云,腾讯,网易目前都是一样的)

From和User:填写送件人的邮箱(目前送件人和账号也都是一样的)

Password:填写邮箱密码(如果启用了授权码,需要填写授权码)

177-1.png


2、如果要测试邮箱配置是否正确,能否发邮件,只要点击Send Email,打开测试界面,To填写收件人的邮箱,Subject是邮件标题,Body是邮件正文,点击发送邮件即可测试。

177-2.png


3、通过脚本一键设置

#邮箱配置
#smtp服务器地址
:local smtp "smtp.qiye.aliyun.com"
#账号和寄件人地址(一般都是同一个)
:local mail "do_not_reply@mail.77bx.com"
#密码
:local pass "77bx.com"
#是否启用TLS,yes或no
:local tls "yes"
#端口(TLS启用587,不启用是25)
:local port "587"
#收件人
:local tomail "vip@77bx.com"
#配置邮箱
/tool e-mail set start-tls=$tls address=$smtp port=$port from=$mail user=$mail password=$pass


二、RouterOS脚本设置

1、System -> Scripts -> +,新建一个Sendmail的脚本

177-3.png


2、脚本代码

只需要修改tls是yes还是no,配置相匹配,tomail就是收件人邮箱

#是否启用TLS,yes或no
:local tls "yes"
#收件人
:local tomail "vip@77bx.com"

#路由器信息
:local rosdate [/system clock get date]
:local rostime [/system clock get time]
:local rosname [/system identity get name]
:local rosbak ($rosname."-77bx")
/system backup save name=$rosbak

#发送邮件
:local subject ("Mikrotik RouterOS[".$rosname."]邮件备份-".$rosdate."-".$rostime)
:local body ("附件为RouterOS最新的系统备份,备份时间为".$rosdate." ".$rostime."\n奇奇博讯提供技术支持\n网址:https://www.77bx.com/177.html")
/tool e-mail send start-tls=$tls to=$tomail subject=$subject body=$body file=$rosbak
:log info "备份邮件已发送!"


3、System -> Scheduler,新建一条自动任务,就可以发送邮件了。

Start Time选择为startup,Interval填写1d 00:00:00表示1天发送1次,你可以改成自己的备份周期,On Event填写:execute script="sendmail-77bx"表示运行发送邮件脚本。

177-4.png


三、一键脚本

上述操作都可以免除,每次都会设置邮箱,然后再发送备份邮件。

#邮箱配置
#smtp服务器地址
:local smtp "smtp.qiye.aliyun.com"
#账号和寄件人地址(一般都是同一个)
:local mail "do_not_reply@mail.77bx.com"
#密码
:local pass "77bx.com"
#是否启用TLS,yes或no
:local tls "yes"
#端口(TLS启用587,不启用是25)
:local port "587"
#收件人
:local tomail "vip@77bx.com"
#配置邮箱
/tool e-mail set start-tls=$tls address=$smtp port=$port from=$mail user=$mail password=$pass

#路由器信息和备份
:local rosdate [/system clock get date]
:local rostime [/system clock get time]
:local rosname [/system identity get name]
:local rosbak ($rosname."-77bx")
/system backup save name=$rosbak

#发送邮件
:local subject ("Mikrotik RouterOS[".$rosname."]邮件备份-".$rosdate."-".$rostime)
:local body ("附件为RouterOS最新的系统备份,备份时间为".$rosdate." ".$rostime."\n奇奇博讯提供技术支持\n网址:https://www.77bx.com/177.html")
/tool e-mail send start-tls=$tls to=$tomail subject=$subject body=$body file=$rosbak
:log info "备份邮件已发送!"


四、备份说明

每次脚本执行会覆盖上次的备份邮件,覆盖完备份再发送备份邮件,所以完全不存在备份会撑爆磁盘的问题。

目前有 0 条评论

    • QQ
    • 填好QQ,点击获取自动填写昵称和邮箱
    • 昵称
    • 邮箱
    • 网址