当前位置:首页 > 原创教程 > RouterOS OSPF基础配置

RouterOS OSPF基础配置

原创教程 / 星之宇 / 2022-6-14 11:46 / 浏览:570 / 评论:0

开放式最短路径优先(Open Shortest Path First,OSPF)是广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。


本文主要介绍下RouterOS下OSPF的基础配置。

一、环境介绍

1、ROS-1和ROS-2 2个RouterOS v6.x版本

2、通过OSPF实现互通

160-1.png


二、基本配置

1、保证ROS-1和ROS-2能正常上网

2、保证ROS-2通过VPN能接入ROS-1

这边详细配置过程我就不写了,可以看看我以前的文章。


三、OSPF配置

1、OSPF增加工作网络接口。Routing --> OSPF --> Interfaces --> + ,Interface是网络接口,我这边选择了all,Cost和Priority不会的可以默认即可。

160-2.png


2、配置RID。Instances选项卡,点开default(没有就新建),Router ID就是RID,需要保证每个路由器的RID是不通的,所以我这边修改了ROS-1路由器的RID为0.0.0.1,ROS-2路由器的RID为0.0.0.2

160-3.png


3、宣告网段

Networks --> + ,添加VPN网段,添加本地网段。

ROS-1添加10.0.0.0/24,10.1.0.0/24,192.168.10.0/24

ROS-2添加10.0.0.0/24,10.2.0.0/24

160-4.png


4、配置Area

这边使用RouterOS的默认Area设置就好,Area ID为0.0.0.0。这边就不详细说明了。


到此已经配通,看到ROS-2已经看到Distance为110的3条路由。

160-5.png


ROS-1配置命令:

/routing ospf instance set [ find default=yes ] router-id=0.0.0.1
/routing ospf interface add
/routing ospf network add area=backbone network=10.0.0.0/24
/routing ospf network add area=backbone network=10.1.0.0/24
/routing ospf network add area=backbone network=192.168.10.0/24

ROS-2配置命令:

/routing ospf instance set [ find default=yes ] router-id=0.0.0.2
/routing ospf interface add
/routing ospf network add area=backbone network=10.0.0.0/24
/routing ospf network add area=backbone network=10.2.0.0/24

目前有 0 条评论

    • QQ
    • 填好QQ,点击获取自动填写昵称和邮箱
    • 昵称
    • 邮箱
    • 网址