当前位置:首页 > 原创教程 > RouterOS使用no-ip实现DDNS动态解析

RouterOS使用no-ip实现DDNS动态解析

原创教程 / 星之宇 / 2023-5-22 21:25 / 浏览:288 / 评论:0

no-ip是一个提供免费二级域名和免费DNS域名解析服务的网站。


下面主要讲讲RouterOS使用no-ip DDNS动态解析的方法

1、no-ip账号

注册并配置好二级域名。(这边不详细说明了,如果不明白的可以评论咨询)

no-ip官网地址:https://www.noip.com


2、RouterOS脚本

Winbox中,System -> Scheduler,新建计划任务,Interval设置为00:00:30(表示30秒运行次)。

:local user "申请的二级域名Key用户名"
:local pass "申请的二级域名key密码"
:local domain "申请的二级域名"
:local ether "pppoe拨号名称"

#以下请勿修改
:local dnsip [/ip address get [/ip address find interface=$ether] address]
:set dnsip [:pick $dnsip 0 [:find $dnsip "/"]]
:global lastip
:if ($lastip!=$dnsip) do={
  :local dnsurl "http://dynupdate.no-ip.com/nic/update\3Fmyip=$dnsip&hostname=$domain"
  :local result [/tool fetch url=$dnsurl user=$user password=$pass as-value output=user] 
  :set result [:pick ($result->"data") 0 4]
  :if ($result="good") do={
    :log info "DDNS: Updated with $dnsip Success."
    :set lastip $dnsip
  } else={
    :log info "DDNS: Update with $dnsip Failed."
  }
}

目前有 0 条评论

    • 昵称
    • 邮箱
    • 网址