当前位置:首页 > 原创教程 > RouterOS基于WireGuard隧道和安卓Android组网

RouterOS基于WireGuard隧道和安卓Android组网

原创教程 / 星之宇 / 2023-5-21 20:00 / 浏览:14088 / 评论:6

安卓Android 12开始移除了PPTP和L2TP导致VPN配置很麻烦,目前只支持iKev2。所以WireGuard成了一种新的选择,它是一种实现加密虚拟专用网络(VPN) 的通信协议和免费开源软件。


以下教程请只用于研究,请勿用于非法用途。

一、安装准备

1、RouterOS V7.1 Beta2+(从这个版本开始支持WireGuard)

2、WireGuard安卓安装包(文章末尾有下载,当前最新版2023.5.12)


二、RouterOS配置WireGuard

1、WireGurad -> + ,添加新的WireGuard接口,Name随便填,Private Key不用填会自动生成,直接点击 OK

322-1.png


2、IP -> Addresses -> +,Address填写网址(如172.16.1.1/24),Interface选择刚才创建的WireGuard接口,点击 OK

322-2.png


代码命令如下:

[admin@77bx-com] > /interface wireguard add listen-port=13231 name=wireguard-wj
[admin@77bx-com] > /ip address add address=172.16.1.1/24 interface=wireguard-wj


三、手机WireGuard配置

1、安装WireGuard,可能手机会提示安全问题(忽略即可),并打开软件,首先需要配置本地接口

名称随便输入,私钥可以自动生成,公钥直接产生,局域网IP地址和端口填写RouterOS WireGuard同网段的IP和端口(如172.16.1.2,13231),DNS服务器根据需求填写,也可以使用RouterOS的DNS,完成后保存下,可以看到出现了添加节点。


2、添加节点。公钥填写RouterOS创建的WireGuard接口的Public Key,对端填写RouterOS公网IP和端口号(如wj.77bx.com:13231),路由IP段可以填写0.0.0.0/0

322-4.png


四、RouterOS配置Peer

1、WireGuard -> Peers -> +,添加Peer,Interface选择wireguard接口,Public Key填写手机生成的公钥,Allowed Address填写0.0.0.0/0,点击 OK

322-3.png


代码命令如下:

[admin@77bx-com] > /interface wireguard peers add allowed-address=0.0.0.0/0 interface=wireguard1 public-key="手机wireguard公钥"


五、手机连接测试

点击开关,发现可以正常连接到RouterOS的WireGuard了,也可以访问局域网的应用了。

322-5.jpg


by 2024-03-16

更新IPv6配置支持,需要使用域名解析到路由器的IPv6地址

只需要更改手机wireguard客户端的配置,远程(Peer)选项卡修改如下:

路由的IP地址(段)填写0.0.0.0/0,::/0

对端填写wj6.77bx.com:13231

目前有 6 条评论

    • 昵称
    • 邮箱
    • 网址

    dz313 2024-04-07 14:193楼

    如果你有两条宽带,如何使用wireguard 把两条宽带绑定一起来连接远程网络呢?评论

    星之宇 2024-04-07 15:26

    可以看看我以前的文章https://www.77bx.com/154.html,routeros之间的的wireguard互连回复

    y8y8y8 2023-12-13 11:132楼

    这个方法好像对于移动大内网只能使用IPv6的方法不行哇?可否出一个IPv6的链接教程呢?谢谢楼主!!!!评论

    max 2023-12-31 20:58

    我在android客户端上用ddns的ipv6也不行。 不过直接填ipv6地址倒是没问题,如果有解决了这个问题的,麻烦也分享下回复

    uiop 2023-09-08 22:571楼

    请问一下13231这个端口ros自动会打开吗?不需要转发?评论

    星之宇 2023-09-08 23:04

    会自动打开,不需要转发回复