当前位置:首页 > 原创教程 > RouterOS基于WireGuard隧道和Windows组网

RouterOS基于WireGuard隧道和Windows组网

原创教程 / 星之宇 / 2023-5-20 19:06 / 浏览:7747 / 评论:0

以下教程请只用于研究,请勿用于非法用途。

一、安装准备

1、RouterOS V7.1 Beta2+(从这个版本开始支持WireGuard)

2、WireGuard Windows安装包(文章末尾有下载,当前最新版0.5.3)


二、RouterOS配置WireGuard

1、WireGurad -> + ,添加新的WireGuard接口,Name随便填,Private Key不用填会自动生成,直接点击 OK

323-1.png


2、IP -> Addresses -> +,Address填写网址(如172.16.1.1/24),Interface选择刚才创建的WireGuard接口,点击 OK

323-2.png

代码命令如下:

[admin@77bx-com] > /interface wireguard add listen-port=13231 name=wireguard-77bx
[admin@77bx-com] > /ip address add address=172.16.1.1/24 interface=wireguard-77bx


三、电脑WireGuard配置

1、安装WireGuard,并打开软件,新建空隧道

323-3.png


2、添加隧道配置文件。名称随便填写,按以下配置输入,然后保存即可。

[Interface]
PrivateKey = 电脑客户端私钥
Address = 本地WireGuard IP,需要和服务器同一段
DNS = DNS服务器地址,可以是RouterOS的DNS

[Peer]
PublicKey = RouterOS公钥
AllowedIPs = 允许的IP,可以直接是0.0.0.0/0
Endpoint = 远程服务器的地址,如wj.77bx.com:13231

323-4.png


四、RouterOS配置Peer

1、WireGuard -> Peers -> +,添加Peer,Interface选择wireguard接口,Public Key填写电脑客户端生成的公钥,Allowed Address填写0.0.0.0/0,点击 OK

323-5.png


代码命令如下:

[admin@77bx-com] > /interface wireguard peers add allowed-address=0.0.0.0/0 interface=wireguard1 public-key="电脑客户端wireguard公钥"


五、连接测试

点击连接,发现可以正常连接到RouterOS的WireGuard了,也可以访问局域网的应用了。

323-6.png

目前有 0 条评论

    • 昵称
    • 邮箱
    • 网址