当前位置:首页 > 原创教程 > RouterOS多IP使用src-nat上网并对应内网IP地址

RouterOS多IP使用src-nat上网并对应内网IP地址

原创教程 / 星之宇 / 2021-5-17 12:00 / 浏览:1929 / 评论:0

本教程主要介绍 RouterOS(以下简称ROS)多IP(多拨或者多宽带)使用src-nat上网,并指定内网的IP通过指定线路上网。

平时的教程都是masquerade伪装上网,所以这次星知苑出品的这个教程使用的是src-nat上网,主要是因为src-nat的效率比masquerade的高。

本教程不适合初学者,过程中很多步骤略过怎么配置,初学者请先学习ROS基本配置再过来查看本教程。


一、环境介绍

1、ESXi6.5虚拟机虚拟ROS、Win7和WinXP

2、ROS多网卡,分别连接2个外网WAN1和WAN2,内网LAN连接Win7和WinXP

3、ROS版本6.44.5

54-1.png


二、ROS配置

1、ROS配置路由器地址:192.168.10.1,配置DHCP,使客户机动态获取到IP,这边客户机Win7获取到了192.168.10.254,WinXP获取到了192.168.10.253,网关都是192.168.10.1


2、ROS配置PPPoE拨号,不够添加默认路由的配置 ,分别添加PPPoE-OUT1和PPPoE-OUT2

54-2.png


3、添加PPPoE-OUT1和PPPoE-OUT2的路由,IP --> Routes,并做标记,这边我标记为out1和out2

54-3.png


4、IP --> Firewall --> Mangle设置规则,内网IP走指定标记的路由,如192.168.10.254走out1,192.168.10.253走out2。

54-4.png

54-5.png


5、IP --> Firewall --> NAT做src-nat上网。如192.168.10.254通过pppoe-out1上网,192.168.10.253通过pppoe-out2上网,并分别设置好Comment,便于脚本更新外网IP地址

54-6.png

54-7.png


6、更新外网IP地址脚本,需定时执行(我这里只提供单个IP更新脚本)


:local status [/interface get [/interface find  name="pppoe-out1"] running]
:if ($status=true) do={
:local oldip [/ip firewall nat get [find comment="out1"] to-addresses]
:local newip [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address]
:set newip [:pick $newip 0 ([:len $newip] -3)]
:if ($newip!=$oldip) do={
/ip firewall nat set [/ip firewall nat find comment="out1"] to-addresses=$newip
}
}



7、到此可以上网了,都是不同的IP地址

54-8.png

目前有 0 条评论

    • QQ
    • 填好QQ,点击获取自动填写昵称和邮箱
    • 昵称
    • 邮箱
    • 网址