站点动态:欢迎您!今天是 2024-06-22 星期六!
RouterOS V7.12使用MACVLAN多拨

RouterOS从7.12开始支持Linux虚拟网卡技术Macvlan,可以在单个物理接口上创建多个macvlan虚拟接口,使配置更灵活方便。

以前要实现单口多拨,要求MAC地址不一样的,实现比较麻烦,需要通过briage来实现,现在有了macvlan,多拨会非常方便。


操作方法

1、使用Winbox,Interface --> MACVLAN --> +,增加一条macvlan记录。

MAC Address:填写你自己的mac地址

Interface:ether1(选择连接到光猫的物理网口)

小米澎湃OS去除视频彩铃

最近打电话手机动不动就会出现视频彩铃广告,有的广告质量很低,那么如何去除广告呢?


操作方案

1、小米手机需要升级到澎湃OS(Xiaomi HyperOS),需要开启开发者选项才可以设置。设置 -> 我的设备 -> 全部参数与信息,多次点击 OS版本 或 Android版本 开启开发者模式。

解决爱快iKuai桥接PPPoE模式下无法访问光猫

问题描述

很多人将光猫改为桥接模式(或者使用猫棒),使用爱快iKuai路由器拨号后,发现不能再通过路由器访问光猫后台了。


问题分析

光猫改桥接后,会把PPPoE的帧直接透传给上行接口,对于爱快iKuai路由器来说,就像直接用一根网线连接了远端PPPoE服务器,所以当我们访问192.168.1.1时,数据直接发送给了远端服务器,所以无法访问光猫。

小米澎湃OS通知栏后出现网络可能受到监控

问题描述

小米澎湃OS下拉通知栏后出现“网络可能受到监控”提示,点开提示“此设备上已安装证书授权中心。您的安全网络流量可能会受到监控或修改。”


问题分析

这是系统的保护机制,出现的原因是因为手机上可能安装了带了CA证书的第三方应用,这样的应用可以对手机的网络数据进行监控或是修改。

本文主要讲解如何借助DNSPOD的新版API接口来实现RouterOS的DDNS动态解析。

看到DNSPOD官网有即将下架老版本API的提示,所以使用新版本的API来写了一个更新接口。


一、创建Token添加域名

首先域名要在DNSPOD解析,然后在腾讯云后台开启的API Token。

详细开通API Token教程:https://console.cloud.tencent.com/cam/capi


二、PHP制作DNSPOD API动态解析接口

以下是我制作好的php解析接口,支持SSL

解析接口

http://api.77bx.com/dnspod/dnspod.php https://api.77bx.com/dnspod/dnspod.php


HTTP请求方式

POST/GET


请求参数

参数名称 必选 类型 描述 id 是 String 腾讯云API密钥SecretId key 是 String 腾讯云API密钥SecretKey domain 是 String 域名。如77bx.com record 否 String 主机记录。如不传默认为@ type 否 String 记录类型。如不传默认为A记录 ip 否 String IP地址。如不传默认为来源IPv4地址


请求事例

curl -X POST http://api.77bx.com/dnspod/dnspod.php -d "id=SecretId&key=SecretKey&domain=77bx.com&record=op&ip=1.1.1.1&type=A"


请求输出

返回提示 描述 0 表示更新成功(当前IP地址和域名IP地址相同也返回0) 1 参数错误 2 域名或API密钥错误 3 更新或API密钥错误


安全说明

1、本接口未记录所有的解析token和解析记录,但是服务器的访问日志会有链接记录(按照政策要求需保存6个月的日志)。虽然有日志但是本接口不提供任何查询。

2、建议使用独立的DNSPOD账号来使用本接口,重要的域名请自建PHP服务器用来解析。由于使用本接口出现的任何安全问题,本人概不负责。这边只能保证本人不会去做任何后门行为。这边建议如果使用了本接口请勤换token(token可以管理账号下的所有域名)。


源代码

暂时不提供


RouterOS脚本

#PPPoE :local pppoe "pppoe-out1" #DNSPOD Token :local secretid "secretid" :local secretkey "secretkey" #DNSPOD域名 :local record "op1" :local domain "77bx.com" #以下非专业人士请勿修改 :global ipold :local ipnew [/ip address get [/ip address find interface=$pppoe] address] :set ipnew [:pick $ipnew 0 ([len $ipnew] -3)] :if ($ipnew != $ipold ) do={ :local postdata "id=$secretid&key=$secretkey&domain=$domain&record=$record&ip=$ipnew" :local response [/tool fetch http-method="post" url=http://api.77bx.com/dnspod/dnspod.php http-data=$postdata as-value output=user] :if ($response->"data" = "0") do={ :log info "DDNS: changed $ipold to $ipnew" :set ipold $ipnew } }

以上脚本需要修改pppoe(宽带拨号的名称),secretid,secretkey,record和domain

注意:ROS可以设置定时1分钟执行一次脚本,脚本中带有ip是否相同判断,相同就不执行;然后是我做的API接口后台中也有ip是否相同的判断,一般不会引起DNSPOD锁域名的情况。

Proxmox VE设置多个管理地址

Proxmox VE(以下简称PVE)设置多个管理地址,用于内外网或独立vlan下的管理。


操作方法

1、PVE后台,打开pve主机,系统 --> 网络 --> 创建 --> Linux Briage,IPv4/CIDR填写IP地址(如10.1.0.188/24),桥接端口填写网口(如ens36),点击创建


2、网关设置(只支持设置一个网关),建议设置为外网可以访问的网卡上。编辑vmbr0删除网关,点击ok;编辑vmbr1填写网关,点击ok,点击应用配置生效。

群晖DSM安装iperf3网络测试软件

经常折腾网络的一定知道iperf3也一定用过,iperf3是一个TCP、UDP 和SCTP网络带宽测量工具,是用于主动测量IP网络上可达到的最大带宽的工具,它支持调整与时序,协议和缓冲区有关的各种参数,而且检测得吞吐量/比特率,损耗等其他参数。


本文主要讲群晖DSM7安装iperf3网络测试软件。

1、群晖安装iperf3

因为群晖将很多Linux命令行工具移除,所以需要使用这些工具就有点麻烦了。不过现在有开源社区做第三方的群晖插件。